How I Made StarCraft II Work

I bought StarCraft II as a digital download on Sunday and began a long hard slog of zero fun.

The first thing I got to enjoy was disabling peer-to-peer in the Blizzard Downloader so my network connection wouldn’t repeatedly die. Still don’t know what that was about, but it definitely made for a long downloading experience.

Wait for the paint to dry, then install, patch, fire it up, start the tutorial, SPLATCRASH *@!*#&!

My steps for fixing this problem:

  1. Whined about it on Twitter and Facebook.
  2. Updated video drivers.
  3. Crash.
  4. Updated audio drivers, which immediately forgot about my front panel audio in.
  5. Reverted audio drivers.
  6. Ran the Windows 7 built-in memory diagnostic. Waste of time, but it felt like doing something.
  7. Crash.
  8. Ran CHKDSK with surface scan. Waste of time, but it felt like doing something.
  9. Crash.
  10. Whined about it on Twitter and Facebook.
  11. Added these settings in Documents/StarCraft II/Variables.txt:
  12. Disabled 3D portraits through the menu settings.
  13. Works!

Actually, I should probably hold off on “Works!”, since my test was “Does this run the first tutorial for more than 10 seconds?” For now, it feels like doing something.

For the dorks, some specs of my entirely mediocre PC, which largely meets the “Recommended Specifications” listing I read the other day:

Operating System: Windows 7 Professional 64-bit (6.1, Build 7600) (7600.win7_gdr.100226-1909)
Language: English (Regional Setting: English)
System Manufacturer: System manufacturer
System Model: P5K
BIOS: BIOS Date: 10/14/08 13:59:09 Ver: 08.00.12
Processor: Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz (2 CPUs), ~2.7GHz
Memory: 2048MB RAM
Available OS Memory: 2048MB RAM
Card name: NVIDIA GeForce 8800 GT
Manufacturer: NVIDIA
Chip type: GeForce 8800 GT
Driver Version: